Configuración de VLSM y OSPF

By Jose Alberto Gallardo Pérez miércoles, 9 de abril de 2014
Hoy vamos a ver enrutamiento dinámico con OSPF en una red con tres Routers y tres PCs en la que vamos previamente vamos a crear un diseño VLSM de acuerdo con los requisitos que vamos a ver a continuación. El esquema de red es el que podemos ver en la siguiente imagen, y el ejercicio que podemos realizar en el simulador Packet Tracert puedes descargarlo aquí para realizar la práctica desde 0. Al acabar, si todo a ido bien deberías de llegar al 100%.


A lo largo de esta práctica vamos a aprender los siguientes conceptos
  • Crear un diseño de VLSM eficaz de acuerdo con determinados requisitos
  • Asignar direcciones adecuadas a las interfaces y documentarlo
  • Conectar una red de acuerdo con el Diagrama de topología
  • Configurar routers incluyendo OSPF
  • Configurar y propagar una ruta estática predeterminada
  • Verificar el funcionamiento OSPF

Paso 1: Diseño de VLSM

El diseño de VLSM deberá cumplir los siguientes requisitos. La red 172.20.0.0/16 debe dividirse en subredes para proporcionar direcciones para las LAN y los enlaces seriales. Es muy recomendable realizar los cálculos de VLSM en papel.

La LAN de HQ necesitará 8000 direcciones

Red : 172.20.0.0/19 --- Broadcast : 172.20.31.255/19

La LAN de Branch1 necesitará 4000 direcciones

Red : 172.20.32.0/20 ---  Broadcast : 172.20.47.255/20

La LAN de Branch2 necesitará 2000 direcciones

Red : 172.20.48.0/21 --- Broadcast : 172.20.55.255/20

Los enlaces entre los routers necesitarán dos direcciones para cada enlace

Red : 172.20.56.0/30 --- Broadcast : 172.20.56.3/30
Red : 172.20.56.4/30 --- Broadcast : 172.20.56.7/30
Red : 172.20.56.8/30 --- Broadcast : 172.20.56.11/30

La dirección loopback que representa en vínculo entre el router HQ y el ISP utilizará la red 10.10.10.0/30.


Red : 10.10.10.0/30 --- Broadcast : 10.10.10.3/30

Paso 2: Asigne las direcciones a las interfaces

-Recordamos que para introducir una ip a una interfaz en un router Cisco haremos doble clic sobre él, entramos a la pestaña CLI y haceremos lo siguiente...

Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface <nombre de la interfaz>
Router(config-if)#ip address <Direccion IP interfaz> <Máscara de red>
Router(config-if)#no shutdown

-Mientras que para introducir una IP a un PC nos iremos a Desktop > IP Configuration

IP Address : 172.20.31.254
Subnet Mask : 255.255.224.0
Default Gateway : 172.20.0.1

-Para que el ejercicio quede de forma correcta y al 100% debemos introducir IPs que correspondan a las que vamos a ver a continuación. 

Asigne la primera dirección de host válida en la red 10.10.10.0/30 para la interfaz Loopback 1 en el router HQ. Haremos lo siguiente.

Router(config)#interface loopback0
Router(config-if)#ip address 10.10.10.1 255.255.255.252

Asigne la primera dirección IP válida de la red LAN de HQ a la interfaz LAN del router HQ. Haremos lo siguiente.

Router(config-if)#interface fa0/0
Router(config-if)#ip address 172.20.0.1 255.255.224.0
Router(config-if)#no shutdown

Asigne la última dirección IP válida de la red LAN de HQ a la PC2.

IP Address : 172.20.31.254
Subnet Mask : 255.255.224.0
Default Gateway : 172.20.0.1

Asigne la primera dirección IP válida de la red LAN de Branch1 a la interfaz LAN del router Branch1.

Router(config)#interface fa0/0
Router(config-if)#ip address 172.20.32.1 255.255.240.0
Router(config-if)#no shutdown

Asigne la última dirección IP válida de la red LAN de Branch1 a PC1.

IP Address : 172.20.47.254
Subnet Mask : 255.255.224.0
Default Gateway : 172.20.32.1

Asigne la primera dirección IP válida de la red LAN de Branch2 a la interfaz LAN del router Branch2.

Router(config)#interface fa0/0
Router(config-if)#ip address 172.20.48.1 255.255.248.0
Router(config-if)#no shutdown

Asigne la última dirección IP válida de la red LAN de Branch2 a PC3.

IP Address : 172.20.48.1
Subnet Mask : 255.255.248.0
Default Gateway : 172.20.48.1

Asigne la primera dirección IP válida de la red de enlace entre HQ y Branch1 a la interfaz Serial 0/0/0 del router HQ.

Router(config)#interface s0/0/0
Router(config-if)#ip address 172.20.56.1 255.255.255.252
Router(config-if)#no shutdown

Asigne la última dirección IP válida de la red de enlace entre HQ y Branch1 a la interfaz Serial 0/0/0 del router Branch.

Router(config)#interface s0/0/0
Router(config-if)#ip address 172.20.56.2 255.255.255.252
Router(config-if)#no shutdown

Asigne la primera dirección IP válida de la red de enlace entre HQ y Branch2 a la interfaz Serial 0/0/1 del router HQ.

Router(config)#interface s0/0/1
Router(config-if)#ip address 172.20.56.5 255.255.255.252
Router(config-if)#no shutdown

Asigne la última dirección IP válida del HQ a la red de enlace Branch2 para la interfaz Serial0/0/1 del router Branch2.

Router(config)#interface s0/0/1
Router(config-if)#ip address 172.20.56.6 255.255.255.252
Router(config-if)#no shutdown

Asigne la primera dirección IP válida del HQ a la red de enlace Branch1 para la interfaz Serial 0/0/1 del router Branch1.

Router(config)#interface s0/0/1
Router(config-if)#ip address 172.20.56.9 255.255.255.252
Router(config-if)#no shutdown 

Asigne la última dirección IP válida del Branch1 a la red de enlace Branch2 para la interfaz Serial0/0/0 del router Branch2.

Router(config)#interface s0/0/0
Router(config-if)#ip address 172.20.56.10 255.255.255.252
Router(config-if)#no shutdown 

*Al acabar la configuración de las interfaces el resultado del ejercicio será del 78%


Paso 3: Preparar la red

Configure el nombre de host del router. (En cada Router)

Router(config)#hostname HQ
Router(config)#hostname Branch1
Router(config)#hostname Branch2

Desactive la búsqueda de DNS. (En cada Router)

Router(config)#no ip domain-lookup 

Configure una contraseña de modo EXEC. (En cada Router)

Router(config)#enable secret class

Configure un mensaje del día. (En cada Router)

Router(config)#banner motd #Bienvenido a la consola#

Configure una contraseña para las conexiones de la consola. (En cada Router)

Router(config)#line console 0
Router(config-line)#password cisco
Router(config-line)#login

Configure una contraseña para las conexiones de VTY. (En cada Router)

Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login

Configure un tiempo de espera EXEC de 15 minutos. (en cada Router)

Router(config-line)#exec
Router(config-line)#exec-timeout 15

Configurar el clockrate de las interfaces DCE en 64000 

HQ(config)#interface s0/0/1
HQ(config-if)#clock rate 64000

Branch1(config)#interface s0/0/0
Branch1(config-if)#clock rate 64000

Branch2(config)#interface s0/0/0
Branch2(config-if)#clock rate 64000

Paso 4: Configuración de OSPF

Configuración OSPF en Router HQ

HQ(config)#router ospf 1
HQ(config-router)#network 172.20.32.0 0.0.15.255 area 0
HQ(config-router)#network 172.20.48.0 0.0.7.255 area 0

Configuración OSPF en Router Branch 1

Branch1(config)#router ospf 1
Branch1(config-router)#network 172.20.0.0 0.0.31.255 area 0
Branch1(config-router)#network 172.20.48.0 0.0.7.255 area 0

Configuración OSPF en Router Branch2

Branch2(config)#router ospf 1
Branch2(config-router)#network 172.20.0.0 0.0.31.255 area 0
Branch2(config-router)#network 172.20.32.0 0.0.15.255 area 0

Configuracion extra de OSPF

Además de estas configuraciones tendremos que tener en cuenta lo siguiente:

Tendremos que deshabilitar las actualizaciones de OSPF para las redes LAN. Para ello en cada Router usaremos el comando passive interface.

Branch2(config)#router ospf 1
Router(config-router)#passive-interface fa0/0

Utilizaremos el comando default-information originate para incluir la ruta estática en las actualizaciones 
OSPF que se envían desde el Router HQ. Esto lo realizaremos sólo en el Router HQ

HQ(config-router)#default-information originate

Por último configuraremos la ruta estática por defecto que simula el enlace de ISP.

HQ(config-if)#ip route 0.0.0.0 0.0.0.0 loopback1

*Al acabar la configuración de las interfaces el resultado del ejercicio será del 100%
José Alberto Gallardo Pérez

Soy un sevillano de 25 años, proyecto de ingeniero, profe de ajedrez, escéptico, loco, con mil ideas en la cabeza y poco tiempo para desarrollarlas. A veces me da por crear contenido en Monetizalia, Gallardowork, MusicCopyleft o donde estas ahora mismo.

No Comment to " Configuración de VLSM y OSPF "